[ Back to Support Page ]

Search the FAQ and Manual:

FAQ: Syncing with CLZ Cloud / Connect

Which version of the Windows/Mac software do I need to sync with CLZ Cloud?

These are the minimum versions required to sync with CLZ Cloud:
  • Music Collector 9.2 for Windows or 3.5 for Mac.
  • Movie Collector 6.3 for Windows or 3.0 for Mac.
  • Book Collector 6.3 for Windows or 3.3 for Mac.
  • Comic Collector 4.6 for Windows or 5.0 for Mac.
  • Game Collector 3.4 for Windows.
Was this helpful? Yes    No


Can't find the answer to your question?

If you tried searching the FAQ and Manual and you were not able to find your answer,
then please Contact us directly using the Support Request Form.

Alternatively, ask other users on the User Forum

The Music Collector User Forum is a great place to discuss questions and suggestions with other Music Collector users.

IMPORTANT: If your question requires an answer from a Collectorz.com employee (e.g. for license issues, bug reports, etc..), it's better to contact us directly using the Support Request Form

(Creating a forum account is free, just use the Register link at the top right.)